b59e357979c48710e7b7464925c70995c7db570a
[asterisk/asterisk.git] / contrib / scripts / install_prereq
1 #! /bin/sh
2 #
3 # $Id$
4 #
5
6 # install_prereq: a script to install distribution-specific
7 # prerequirements
8
9 set -e
10
11 usage() {
12   echo "$0: a script to install distribution-specific prerequirement"
13   echo 'Revision: $Id$'
14   echo ""
15   echo "Usage: $0:                    Shows this message."
16   echo "Usage: $0 test                Prints commands it is about to run."
17   echo "Usage: $0 install             Really install."
18   echo "Usage: $0 install-unpackaged  Really install unpackaged requirements."
19 }
20
21 # Basic build system:
22 PACKAGES_DEBIAN="build-essential"
23 # Asterisk: basic requirements:
24 PACKAGES_DEBIAN="$PACKAGES_DEBIAN libncurses-dev libz-dev libssl-dev libxml2-dev libsqlite3-dev uuid-dev uuid"
25 # Asterisk: for addons:
26 PACKAGES_DEBIAN="$PACKAGES_DEBIAN libcurl-dev libspeex-dev libspeexdsp-dev libogg-dev libvorbis-dev libasound2-dev portaudio19-dev libcurl4-openssl-dev"
27 PACKAGES_DEBIAN="$PACKAGES_DEBIAN libpq-dev unixodbc-dev libsqlite0-dev libmysqlclient15-dev libneon27-dev libgmime-dev libusb-dev liblua5.1-0-dev lua5.1"
28 PACKAGES_DEBIAN="$PACKAGES_DEBIAN libopenh323-dev libvpb-dev libgtk2.0-dev libmysqlclient-dev libbluetooth-dev libradiusclient-ng-dev freetds-dev"
29 PACKAGES_DEBIAN="$PACKAGES_DEBIAN libsnmp-dev libiksemel-dev libcorosync-dev libnewt-dev libpopt-dev libical-dev libspandsp-dev libjack-dev"
30 PACKAGES_DEBIAN="$PACKAGES_DEBIAN libresample-dev libc-client-dev binutils-dev libsrtp-dev libgsm1-dev libedit-dev doxygen"
31 PACKAGES_RH="automake gcc gcc-c++ ncurses-devel openssl-devel libxml2-devel unixODBC-devel libcurl-devel libogg-devel libvorbis-devel speex-devel"
32 PACKAGES_RH="$PACKAGES_RH spandsp-devel freetds-devel net-snmp-devel iksemel-devel corosynclib-devel newt-devel popt-devel libtool-ltdl-devel lua-devel"
33 PACKAGES_RH="$PACKAGES_RH libsqlite3x-devel radiusclient-ng-devel portaudio-devel postgresql-devel libresample-devel neon-devel libical-devel"
34 PACKAGES_RH="$PACKAGES_RH openldap-devel gmime22-devel sqlite2-devel mysql-devel bluez-libs-devel jack-audio-connection-kit-devel gsm-devel libedit-devel libuuid-devel"
35
36 PACKAGES_OBSD="popt gmake wget libxml libogg libvorbis curl iksemel spandsp speex iodbc freetds-0.63p1-msdblib mysql-client gmime sqlite sqlite3 jack"
37
38 KVERS=`uname -r`
39
40 case "$1" in
41 test)    testcmd=echo ;;
42 install) testcmd='' ;;
43 install-unpackaged) unpackaged="yes" ;;
44 '') usage; exit 0 ;;
45 *) usage; exit 1 ;;
46 esac
47
48 in_test_mode() {
49   test "$testcmd" != ''
50 }
51
52 check_installed_debs() {
53         aptitude -F '%c %p' search "$@" 2>/dev/null \
54         | awk '/^p/{print $2}'
55 }
56
57 # parsing the output of yum is close to impossible.
58 # We'll use rpm and hope for the best:
59 check_installed_rpms() {
60         for pack in "$@"
61         do
62                 if ! rpm -q $pack >/dev/null 2>/dev/null
63                 then echo $pack
64                 fi
65         done
66 }
67
68 check_installed_pkgs() {
69         for pack in "$@"
70         do
71                 if [ `pkg_info -a | grep $pack | wc -l` = 0 ]; then
72                 echo $pack
73                 fi
74         done
75 }
76
77 handle_debian() {
78         # echo "# Distribution is Debian or compatible"
79         extra_packs=`check_installed_debs $PACKAGES_DEBIAN`
80         $testcmd aptitude install -y $extra_packs
81 }
82
83 handle_rh() {
84         # echo "# Distribution is RedHat-based or compatible"
85         extra_packs=`check_installed_rpms $PACKAGES_RH`
86         # FIXME: is there yum with RHEL 4?
87         $testcmd yum install -y $extra_packs
88 }
89
90 handle_obsd() {
91         # echo "# Distribution is OpenBSD or compatible"
92         extra_packs=`check_installed_pkgs $PACKAGES_OBSD`
93         $testcmd pkg_add $extra_packs
94 }
95
96 install_unpackaged() {
97         echo "*** Installing NBS (Network Broadcast Sound) ***"
98         svn co http://svn.digium.com/svn/nbs/trunk nbs-trunk
99         cd nbs-trunk
100         make && make install
101         cd ..
102
103         echo "*** Installing libresample ***"
104         svn co http://svn.digium.com/svn/thirdparty/libresample/trunk libresample-trunk
105         cd libresample-trunk
106         ./configure && make && make install
107         cd ..
108 }
109
110 if in_test_mode; then
111         echo "#############################################"
112         echo "## $1: test mode."
113         echo "## Use the commands here to install your system."
114         echo "#############################################"
115 elif test "${unpackaged}" = "yes" ; then
116         install_unpackaged
117         exit 0
118 fi
119
120 OS=`uname -s`
121 unsupported_distro=''
122
123 # A number of distributions we don't (yet?) support.
124 if [ "$OS" != 'Linux' -a "$OS" != 'OpenBSD' ]; then
125   echo >&2 "$0: Your OS ($OS) is currently not supported. Aborting."
126   exit 1
127 fi
128
129 if [ -f /etc/gentoo-release ]; then
130   unsupported_distro='Gentoo'
131 fi
132
133 if [ -f /etc/mandrake-release ]; then
134   unsupported_distro='Mandriva'
135 fi
136
137 if [ -f /etc/SuSE-release ]; then
138   unsupported_distro='SUSE'
139 fi
140
141 if [ -f /etc/slackware-version ]; then
142   unsupported_distro='Slackware'
143 fi
144
145 if [ "$unsupported_distro" != '' ]; then
146   echo >&2 "$0: Your distribution ($unsupported_distro) is currently not supported. Aborting."
147   exit 1
148 fi
149
150 # The distributions we do support:
151 if [ -r /etc/debian_version ]; then
152   handle_debian
153 elif [ -r /etc/redhat-release ]; then
154   handle_rh
155 elif [ "$OS" = 'OpenBSD' ]; then
156   handle_obsd
157 fi
158
159 if ! in_test_mode; then
160   echo "#############################################"
161   echo "## $1 completed successfully"
162   echo "#############################################"
163 fi