Update configure script to be compatible with ptlib 2.10.9
authorMatthew Jordan <mjordan@digium.com>
Tue, 29 Jan 2013 02:12:04 +0000 (02:12 +0000)
committerMatthew Jordan <mjordan@digium.com>
Tue, 29 Jan 2013 02:12:04 +0000 (02:12 +0000)
commit148b6e7fba1d5061bf59b712b72d83cc8d85dd69
treec7a9a5b973b7b8e379f2653236e52456d0c80159
parent986c2a18181de3a5e475dfcb1e93aa9ddeebfe65
Update configure script to be compatible with ptlib 2.10.9

With ptlib 2.10.9, the configure script fails due to grep returning multiple
matches for the pattern it searches for. This patch updates the pattern
matching to return only the actual version for the symbol searched for,
PTLIB_VERSION.

(closes issue ASTERISK-20980)
Reported by: Stefan Reuter
patches:
  ASTERISK-20980-1.patch uploaded by Stefan Reuter (license 5339)
........

Merged revisions 380297 from http://svn.asterisk.org/svn/asterisk/branches/1.8
........

Merged revisions 380298 from http://svn.asterisk.org/svn/asterisk/branches/11

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@380299 65c4cc65-6c06-0410-ace0-fbb531ad65f3
autoconf/ast_check_pwlib.m4
configure
include/asterisk/autoconfig.h.in