Accept T.38 re-INVITE responses with invalid SDP versions.
authorKevin P. Fleming <kpfleming@digium.com>
Mon, 15 Jun 2009 20:42:38 +0000 (20:42 +0000)
committerKevin P. Fleming <kpfleming@digium.com>
Mon, 15 Jun 2009 20:42:38 +0000 (20:42 +0000)
commit85e57521ab6eee3dc866e5882694f054f98b7186
treec017a5551592b3a161dc9bfb9ce377800cfe2483
parentaaeec3b40f147216f6f550de269653eae38e9916
Accept T.38 re-INVITE responses with invalid SDP versions.

This commit changes the 'incoming SDP version' check logic a bit more; when
'ignoresdpversion' is *not* set for a peer, if we initiate a re-INVITE to
switch to T.38, we'll always accept the peer's SDP response, even if they
don't properly increment the SDP version number as they should. If this situation
occurs, a warning message will be generated suggesting that the peer's
configuration be changed to include the 'ignoresdpversion' configuration option
(although ideally they'd fix their SIP implementation to be RFC compliant).

AST-221

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@200689 65c4cc65-6c06-0410-ace0-fbb531ad65f3
channels/chan_sip.c