Fix an ABI compatibility issue with ast_log_safe for modules.
authorCorey Farrell <git@cfware.com>
Mon, 30 Mar 2015 11:43:19 +0000 (11:43 +0000)
committerCorey Farrell <git@cfware.com>
Mon, 30 Mar 2015 11:43:19 +0000 (11:43 +0000)
commit8d12288d8a9e34fc7d8a032decf19e3b24256c20
treeeb89de33329783db35b2404d2b09d8433cc3ae21
parent7bc2345fb16fb0ae616d4573cef6f08db54a2ba3
Fix an ABI compatibility issue with ast_log_safe for modules.

Binary modules are sometimes built against the latest release of
Asterisk in each branch, and need to be compatible with all
releases of that branch.  This change ensures that utils.h only
uses ast_log_safe from the core.  For modules and utilities ast_log
is used instead.

Review: https://reviewboard.asterisk.org/r/4548/
........

Merged revisions 433772 from http://svn.asterisk.org/svn/asterisk/branches/11
........

Merged revisions 433773 from http://svn.asterisk.org/svn/asterisk/branches/13

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@433774 65c4cc65-6c06-0410-ace0-fbb531ad65f3
include/asterisk/utils.h
main/Makefile