Allow H.323 Plus library to be used in addition to the OpenH323 library
authorJeff Peeler <jpeeler@digium.com>
Tue, 17 Mar 2009 20:47:31 +0000 (20:47 +0000)
committerJeff Peeler <jpeeler@digium.com>
Tue, 17 Mar 2009 20:47:31 +0000 (20:47 +0000)
commit9dc40485f212e6adc3ff87f9bdbe1c68cddfde64
tree261d15df0038c3fe050d85bc494340eaed4fe551
parent77b2123a99625dd3c944ebdcf169962c27a16c50
Allow H.323 Plus library to be used in addition to the OpenH323 library

Chan_h323 can now be compiled against both the previously supported versions of
OpenH323 as well as the current H.323 Plus (version 1.20.2). The configure
script has been modified to look in the default install location of h323 to
hopefully help avoid using the environment variables OPENH323DIR and PWLIBDIR.
Also, the CLI command "h323 show version" has been added which indicates which
version of h323 is in use.

(closes issue #11261)
Reported by: vhatz
Patches:
      asterisk-1.6.0.6-h323plus.patch uploaded by jthurman (license 614)

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@182722 65c4cc65-6c06-0410-ace0-fbb531ad65f3
autoconf/ast_check_openh323.m4
channels/chan_h323.c
channels/h323/ast_h323.cxx
channels/h323/ast_h323.h
channels/h323/chan_h323.h
channels/h323/compat_h323.cxx
channels/h323/compat_h323.h
configure