Removed #if checks for crazy old versions of OS X.
authorDavid M. Lee <dlee@digium.com>
Wed, 8 May 2013 20:25:28 +0000 (20:25 +0000)
committerDavid M. Lee <dlee@digium.com>
Wed, 8 May 2013 20:25:28 +0000 (20:25 +0000)
commitec53d7fa87a9a4371468acc7ef67144ca0b7b545
treea3a04c435494aca35e1ef5e995ed86e11b7f79df
parent07e2eb71e991eb1bb0ad2e9b2cb7679803859a63
Removed #if checks for crazy old versions of OS X.

The <arpa/nameser_compat.h> was introduced way back in OS X Panther, which
itself was end-of-lifed back in 2007. We can assume that any OS X machine
we build on will need that header file :-)

Why bother removing it? The flag we're checking (__APPLE_CC__) is actually
Apple's build number. Self-compiled versions of GCC (such as installing the
latest version of GCC from homebrew) sets the value to 0, making it useless
for this sort of compile flaggery.

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@388045 65c4cc65-6c06-0410-ace0-fbb531ad65f3
main/enum.c
main/srv.c