Fix security events for AMI invalid password
authorKinsey Moore <kmoore@digium.com>
Thu, 3 Oct 2013 19:30:33 +0000 (19:30 +0000)
committerKinsey Moore <kmoore@digium.com>
Thu, 3 Oct 2013 19:30:33 +0000 (19:30 +0000)
commitfe4cd68444e58bb61bf0678030d896f3bfb53164
tree1841bb68e9ec2afca27ef565040a4c935c09e03d
parentbd8cf10d60560524a5c90315a85b471d14e61331
Fix security events for AMI invalid password

In r337595, additional security events were added for chan_sip
authentication failures. The new IEs added to the existing invalid
password event were defined as required IEs, but existing users of the
event did not set the new IEs and could not since they didn't apply to
existing uses. They are now marked as optional IEs.

(closes issue ASTERISK-22578)
Reported by: Matt Jordan
........

Merged revisions 400421 from http://svn.asterisk.org/svn/asterisk/branches/11
........

Merged revisions 400440 from http://svn.asterisk.org/svn/asterisk/branches/12

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@400441 65c4cc65-6c06-0410-ace0-fbb531ad65f3
main/security_events.c