openssl 1.1 support: use OPENSSL_VERSION_NUMBER
authorTzafrir Cohen <tzafrir.cohen@xorcom.com>
Sat, 21 Jan 2017 05:57:33 +0000 (07:57 +0200)
committerTzafrir Cohen <tzafrir.cohen@xorcom.com>
Fri, 3 Feb 2017 08:28:14 +0000 (10:28 +0200)
Use OPENSSL_VERSION_NUMBER instead of OPENSSL_API_COMPAT to detect
the openssl 1.1 API.

Change-Id: I4e448f55ef516aedf6ad154037c35577a421a458

main/iostream.c
main/libasteriskssl.c

index 22cd598..6187bc2 100644 (file)
@@ -465,19 +465,19 @@ int ast_iostream_close(struct ast_iostream *stream)
                                        SSL_get_error(stream->ssl, res));
                        }
 
-#if defined(OPENSSL_API_COMPAT) && OPENSSL_API_COMPAT >= 0x10100000L
+#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x10100000L
                        if (!SSL_is_server(stream->ssl)) {
 #else
                        if (!stream->ssl->server) {
 #endif
                                /* For client threads, ensure that the error stack is cleared */
-#if !defined(OPENSSL_API_COMPAT) || OPENSSL_API_COMPAT < 0x10100000L
+#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
 #if OPENSSL_VERSION_NUMBER >= 0x10000000L
                                ERR_remove_thread_state(NULL);
 #else
                                ERR_remove_state(0);
 #endif /* OPENSSL_VERSION_NUMBER >= 0x10000000L */
-#endif  /* !defined(OPENSSL_API_COMPAT) || OPENSSL_API_COMPAT < 0x10100000L */
+#endif  /* !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L */
                        }
 
                        SSL_free(stream->ssl);
index 9905b15..36982e2 100644 (file)
@@ -72,7 +72,7 @@ static void ssl_lock(int mode, int n, const char *file, int line)
        }
 }
 
-#if !defined(OPENSSL_API_COMPAT) || OPENSSL_API_COMPAT < 0x10100000L
+#if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L
 int SSL_library_init(void)
 {
 #if defined(AST_DEVMODE)
@@ -114,7 +114,7 @@ void ERR_free_strings(void)
 {
        /* we can't allow this to be called, ever */
 }
-#endif /* !defined(OPENSSL_API_COMPAT) || OPENSSL_API_COMPAT < 0x10100000L */
+#endif /* !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x10100000L */
 
 #endif /* HAVE_OPENSSL */