add warning about new expression parser
authorKevin P. Fleming <kpfleming@digium.com>
Thu, 1 Sep 2005 21:00:06 +0000 (21:00 +0000)
committerKevin P. Fleming <kpfleming@digium.com>
Thu, 1 Sep 2005 21:00:06 +0000 (21:00 +0000)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@6487 65c4cc65-6c06-0410-ace0-fbb531ad65f3

UPGRADE.txt

index 81f1a5b..3125c1e 100755 (executable)
@@ -12,6 +12,16 @@ Compiling:
   support; systems using that compiler will need to be upgraded to
   a more recent compiler release.
 
+Dialplan Expressions:
+
+* The dialplan expression parser (which handles $[ ... ] constructs)
+  has gone through a major upgrade, but has one incompatible change:
+  spaces are no longer required around expression operators, including
+  string comparisons. However, you can now use quoting to keep strings
+  together for comparison. For more details, please read the
+  doc/README.variables file, and check over your dialplan for possible
+  problems.
+
 Agents:
 
 * The default for ackcall has been changed to "no" instead of "yes"