it appears that current Mac OS/X does not need the poll compatibility module at all...
authorKevin P. Fleming <kpfleming@digium.com>
Mon, 18 Sep 2006 19:20:24 +0000 (19:20 +0000)
committerKevin P. Fleming <kpfleming@digium.com>
Mon, 18 Sep 2006 19:20:24 +0000 (19:20 +0000)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@43207 65c4cc65-6c06-0410-ace0-fbb531ad65f3

main/Makefile

index 037a10a..c1b3978 100644 (file)
@@ -39,6 +39,7 @@ OBJS+=say.o
 
 ifeq ($(wildcard /usr/include/sys/poll.h),)
   OBJS+=poll.o
+  ASTCFLAGS+=-DPOLLCOMPAT
 endif
 
 ifeq ($(wildcard /usr/include/dlfcn.h),)
@@ -59,11 +60,6 @@ ifneq ($(findstring darwin,$(OSARCH)),)
   ifneq ($(findstring LOADABLE_MODULES,$(MENUSELECT_CFLAGS)),)
     ASTLINK=-Wl,-dynamic
   endif
-  # Mac on Intel CoreDuo does not need poll compatibility layer
-  ifneq ($(PROC),i386)
-    OBJS+=poll.o
-    ASTCFLAGS+=-DPOLLCOMPAT
-  endif
 else
 # These are used for all but Darwin
   ifneq ($(findstring LOADABLE_MODULES,$(MENUSELECT_CFLAGS)),)