do complete version check for SpanDSP, since the app_fax code is not compatible with...
authorKevin P. Fleming <kpfleming@digium.com>
Wed, 15 Oct 2008 09:59:12 +0000 (09:59 +0000)
committerKevin P. Fleming <kpfleming@digium.com>
Wed, 15 Oct 2008 09:59:12 +0000 (09:59 +0000)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@149426 65c4cc65-6c06-0410-ace0-fbb531ad65f3

configure
configure.ac

index 5145d3b..487d252 100755 (executable)
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
 #! /bin/sh
-# From configure.ac Revision: 147306 .
+# From configure.ac Revision: 147807 .
 # Guess values for system-dependent variables and create Makefiles.
 # Generated by GNU Autoconf 2.61 for asterisk 1.6.
 #
@@ -205,7 +205,7 @@ if as_func_ret_failure; then
   echo as_func_ret_failure succeeded.
 fi
 
-if (set x; as_func_ret_success y && test x = \"\$1\" ); then
+if ( set x; as_func_ret_success y && test x = \"\$1\" ); then
   :
 else
   exitcode=1
@@ -409,7 +409,7 @@ if as_func_ret_failure; then
   echo as_func_ret_failure succeeded.
 fi
 
-if (set x; as_func_ret_success y && test x = \"\$1\" ); then
+if ( set x; as_func_ret_success y && test x = \"\$1\" ); then
   :
 else
   exitcode=1
@@ -6586,7 +6586,7 @@ else
    GNU_MAKE_VERSION_MINOR=0 ;
    for a in make gmake gnumake ; do
       if test -z "$a" ; then continue ; fi ;
-      if (sh -c "$a --version" 2> /dev/null | grep GNU  2>&1 > /dev/null ) ;  then
+      if ( sh -c "$a --version" 2> /dev/null | grep GNU  2>&1 > /dev/null ) ;  then
          GNU_MAKE=$a ;
          GNU_MAKE_VERSION_MAJOR=`$GNU_MAKE --version | grep "GNU Make" | cut -f3 -d' ' | cut -f1 -d'.'`
          GNU_MAKE_VERSION_MINOR=`$GNU_MAKE --version | grep "GNU Make" | cut -f2 -d'.' | cut -c1-2`
 
 
     if test "x${PBX_SPANDSP}" != "x1" -a "${USE_SPANDSP}" != "no"; then
-        if test "xminimum version of SpanDSP" != "x"; then
-            { echo "$as_me:$LINENO: checking for minimum version of SpanDSP" >&5
-echo $ECHO_N "checking for minimum version of SpanDSP... $ECHO_C" >&6; }
+        if test "xcompatible version of SpanDSP" != "x"; then
+            { echo "$as_me:$LINENO: checking for compatible version of SpanDSP" >&5
+echo $ECHO_N "checking for compatible version of SpanDSP... $ECHO_C" >&6; }
        else
             { echo "$as_me:$LINENO: checking if \"
                #if SPANDSP_RELEASE_DATE < 20080516
                #error \"spandsp 0.0.5 or greater is required\"
                #endif
+               #if SPANDSP_RELEASE_DATE >= 20081012
+               #error \"spandsp 0.0.6 or greater is not supported; use 0.0.5\"
+               #endif
        \" compiles using spandsp/version.h" >&5
 echo $ECHO_N "checking if \"
                #if SPANDSP_RELEASE_DATE < 20080516
                #error \"spandsp 0.0.5 or greater is required\"
                #endif
+               #if SPANDSP_RELEASE_DATE >= 20081012
+               #error \"spandsp 0.0.6 or greater is not supported; use 0.0.5\"
+               #endif
        \" compiles using spandsp/version.h... $ECHO_C" >&6; }
        fi
        saved_cppflags="${CPPFLAGS}"
@@ -40006,6 +40012,9 @@ main ()
                #if SPANDSP_RELEASE_DATE < 20080516
                #error "spandsp 0.0.5 or greater is required"
                #endif
+               #if SPANDSP_RELEASE_DATE >= 20081012
+               #error "spandsp 0.0.6 or greater is not supported; use 0.0.5"
+               #endif
        ;
 
   ;
index 30bcd9d..ad44318 100644 (file)
@@ -1350,7 +1350,10 @@ AST_C_COMPILE_CHECK([SPANDSP], [
                #if SPANDSP_RELEASE_DATE < 20080516
                #error "spandsp 0.0.5 or greater is required"
                #endif
-       ], [spandsp/version.h], , [minimum version of SpanDSP])
+               #if SPANDSP_RELEASE_DATE >= 20081012
+               #error "spandsp 0.0.6 or greater is not supported; use 0.0.5"
+               #endif
+       ], [spandsp/version.h], , [compatible version of SpanDSP])
 
 if test "x${PBX_SPANDSP}" = "x1" ; then
        # We found the correct version in the header, now let's make sure it links