/ fix to for compiling with both 2.4.x and 3.x vpb-drivers
authorBen Kramer <bkramer@voicetronix.com.au>
Wed, 2 Nov 2005 01:43:03 +0000 (01:43 +0000)
committerBen Kramer <bkramer@voicetronix.com.au>
Wed, 2 Nov 2005 01:43:03 +0000 (01:43 +0000)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@6943 65c4cc65-6c06-0410-ace0-fbb531ad65f3

channels/chan_vpb.c

index 76c53af..802d15a 100755 (executable)
@@ -1518,7 +1518,11 @@ static void mkbrd(vpb_model_t model, int echo_cancel)
                        vpb_echo_canc_enable();
                        ast_log(LOG_NOTICE, "Voicetronix echo cancellation ON\n");
                        if (ec_supp_threshold > -1){
+                               #ifdef VPB_PRI
                                vpb_echo_canc_set_sup_thresh(0,(short *)&ec_supp_threshold);
+                               #else
+                               vpb_echo_canc_set_sup_thresh((short *)&ec_supp_threshold);
+                               #endif
                                ast_log(LOG_NOTICE, "Voicetronix EC Sup Thres set\n");
                        }
                }