Reported by Trent Creekmore
[dahdi/tools.git] / Makefile.legacy
index 8bd58ae..b0455bc 100644 (file)
@@ -14,20 +14,6 @@ ifeq ($(strip $(foreach var,clean,$(findstring $(var),$(MAKECMDGOALS)))),)
  endif
 endif
 
-ifneq (,$(findstring ppc,$(UNAME_M)))
-CFLAGS+=-fsigned-char
-endif
-ifneq (,$(findstring x86_64,$(UNAME_M)))
-CFLAGS+=-m64
-endif
-
-ROOT_PREFIX=
-
-# extra cflags to build dependencies. Recursively expanded.
-MAKE_DEPS= -MD -MT $@ -MF .$(subst /,_,$@).d -MP
-
-CFLAGS+=$(DAHDI_INCLUDE)
-
 CHKCONFIG      := $(wildcard /sbin/chkconfig)
 UPDATE_RCD     := $(wildcard /usr/sbin/update-rc.d)
 ifeq (,$(DESTDIR))
@@ -83,10 +69,10 @@ genconf_parameters.sample: xpp/genconf_parameters
 README.html: README system.conf.asciidoc init.conf.asciidoc tonezones.txt \
   UPGRADE.txt genconf_parameters.asciidoc assigned-spans.conf.asciidoc \
   span-types.conf.asciidoc
-       $(ASCIIDOC) -n -a toc -a toclevels=4 $<
+       TZ=UTC $(ASCIIDOC) -n -a toc -a toclevels=4 $<
 
 README.Astribank.html: xpp/README.Astribank
-       $(ASCIIDOC) -o $@ -n -a toc -a toclevels=4 $<
+       TZ=UTC $(ASCIIDOC) -o $@ -n -a toc -a toclevels=4 $<
 
 # on Debian: this requires the full groff, not just groff-base.
 %.8.html: %.8
@@ -100,7 +86,7 @@ install: all install-programs
        @echo "### DAHDI tools installed successfully."
        @echo "### If you have not done so before, install init scripts with:"
        @echo "###"
-       @echo "###   make config"
+       @echo "###   make install-config"
        @echo "###"
        @echo "###################################################"