pjsip: Upgrade bundled version to pjproject 2.12.1
[asterisk/asterisk.git] / autoconf / ast_pkgconfig.m4
1 # Check for pkg-config component $2:
2 # AST_PKG_CONFIG_CHECK([package], [component])
3 AC_DEFUN([AST_PKG_CONFIG_CHECK],
4 [
5    AC_REQUIRE([AST_PROG_SED])dnl
6    if test "x${PBX_$1}" != "x1" -a "${USE_$1}" != "no"; then
7       PKG_CHECK_MODULES($1, $2, [
8             PBX_$1=1
9             $1_INCLUDE=$(echo ${$1_CFLAGS} | $SED -e "s|-std=c99||g")
10             $1_LIB="$$1_LIBS"
11             AC_DEFINE([HAVE_$1], 1, [Define if your system has the $1 libraries.])
12          ], [
13             PBX_$1=0
14          ]
15       )
16    fi
17 ])