These changes are in regards to bug 13249, where users are being surprised by the...
authorSteve Murphy <murf@digium.com>
Tue, 19 Aug 2008 15:59:12 +0000 (15:59 +0000)
committerSteve Murphy <murf@digium.com>
Tue, 19 Aug 2008 15:59:12 +0000 (15:59 +0000)
commit04795d963f633694a8e5eccde3d3baf8b3d87d8d
tree2505d6c6c9a14bce3db2ae69e06120cbe8f30134
parent4d9a38bc3fabc71b75ac107ec2d26873878a3af9
These changes are in regards to bug 13249, where users are being surprised by the changes made
to the Set app in trunk/1.6.x, as they come from the 1.4 world. They are only bitten if
they write their AEL dialplan in the 1.4 world, and then carry it over to a trunk/1.6.x
installation where a "make samples" was executed, or where they hand-edited the
asterisk.conf file and added the [compat] category with app_set = 1.6 (or higher).

(this commit does not totally solve 13249, at least not yet)

The change involves issueing a single warning while the AEL file is loading, if:
 1. app_set is present in the config file, and set to 1.6 or higher.
 2. there are double quotes in an assignment statement (eg x = "hi there";)
 3. the warning was not already issued.

The standalone app, aelparse, does not (yet) issue this warning. I'd have to
have it read in the asterisk.conf file, and that's a bit of hassle. I'll add
it if users request it, tho.

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@138815 65c4cc65-6c06-0410-ace0-fbb531ad65f3
main/pbx.c
res/ael/ael.tab.c
res/ael/ael.tab.h
res/ael/ael.y