Fix segfault introduced by conversion to ACO API
authorTerry Wilson <twilson@digium.com>
Sat, 21 Jul 2012 13:25:26 +0000 (13:25 +0000)
committerTerry Wilson <twilson@digium.com>
Sat, 21 Jul 2012 13:25:26 +0000 (13:25 +0000)
commit13427db64c2c2f3cf15501c998bc982e91f8bf58
treeee0936cb17ee59d620e0e9437075fda3730a204b
parenta5e10001b29207598a203beb475edbc89a02cc4d
Fix segfault introduced by conversion to ACO API

The value "none" is specified in the config file as a valid value for
the "video_mode" option. The code prior to the ACO conversion did not
check for "none", but just ignored it and relied on the default zero
value. The parsing with ACO is more strict, so without handling
"none" specifically, parsing would fail.

When parsing failed, but the module loaded anyway, the config info
would never be stored, and one place in the code did not check for
this case and would segfault. It was also possible that the
aco_info struct's internals would be destroyed and used as well.

This patch keeps the module from loading after parse failures, adds
the "none" option to "video_mode", registers CLI functions only
after parsing has completed, checks the config data for NULL before
accessing it, and returns -1 on some allocation failures when
initializing.

(closes issue ASTERISK-20159)
Reported by: Birger "WIMPy" Harzenetter
Tested by: Birger "WIMPy" Harzenetter
Patches:
    confbridge_fix3.txt uploaded by Terry Wilson

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@370341 65c4cc65-6c06-0410-ace0-fbb531ad65f3
apps/app_confbridge.c
apps/confbridge/conf_config_parser.c
main/config_options.c