LICENSE: Clarify language in Asterisk's LICENSE to allow for linking to UniMRCP
authorMatthew Jordan <mjordan@digium.com>
Thu, 28 Aug 2014 21:54:44 +0000 (21:54 +0000)
committerMatthew Jordan <mjordan@digium.com>
Thu, 28 Aug 2014 21:54:44 +0000 (21:54 +0000)
commit3194892ea2ce0ffc0d420648455223efd7af14a1
tree55c369bd96f33800b5fd738075699268a229fbba
parentc5916fb39f1d6c0fe1292f2d1de5f4e925ef1a1f
LICENSE: Clarify language in Asterisk's LICENSE to allow for linking to UniMRCP

The UniMRCP project distributes Asterisk modules that integrate Asterisk with
UniMRCP, and other Asterisk users use the UniMRCP library as well.
Unfortunately, the UniMRCP license is Apache 2.0, which per the Free Software
Foundation, is not a compatible license with the GPLv2.

"Please note that this license is not compatible with GPL version 2, because it
has some requirements that are not in that GPL version. These include certain
patent termination and indemnification provisions. The patent termination
provision is a good thing, which is why we recommend the Apache 2.0 license for
substantial programs over other lax permissive licenses."

On the other hand, UniMRCP is a great project and we'd like to let people use
it with Asterisk.

This patch updates the LICENSE text to allow users to link Asterisk with
UniMRCP and distribute the resulting binaries.
........

Merged revisions 422293 from http://svn.asterisk.org/svn/asterisk/branches/1.8
........

Merged revisions 422294 from http://svn.asterisk.org/svn/asterisk/branches/11
........

Merged revisions 422295 from http://svn.asterisk.org/svn/asterisk/branches/12
........

Merged revisions 422296 from http://svn.asterisk.org/svn/asterisk/branches/13

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@422297 65c4cc65-6c06-0410-ace0-fbb531ad65f3
LICENSE