(closes issue #13202)
authorSteve Murphy <murf@digium.com>
Sat, 2 Aug 2008 04:51:29 +0000 (04:51 +0000)
committerSteve Murphy <murf@digium.com>
Sat, 2 Aug 2008 04:51:29 +0000 (04:51 +0000)
commit9051edfa4a6c02300f3cfe27b05bfe6fff6232eb
tree3e0c622f990675ca7a9145d76937c9d1c64684a0
parent671627028c3dde78f2704485ae1b2f3d321e3436
(closes issue #13202)
Reported by: falves11
Tested by: murf

falves11 ==

The changes I introduce here seem to clear up the problem
for me. However, if they do not for you, please reopen this
bug, and we'll keep digging.

The root of this problem seems to be a subtle memory corruption
introduced when creating an extension with an empty extension
name. While valgrind cannot detect it outside of DEBUG_MALLOC
mode, when compiled with DEBUG_MALLOC, this is certain death.

The code in main/features.c is a puzzle to me. On the initial
module load, the code is attempting to add the parking extension
before the features.conf file has even been opened!

I just wrapped the offending call with an if() that will not
try to add the extension if the extension name is empty. THis
seems to solve the corruption, and let the "memory show allocations"
work as one would expect.

But, really, adding an extension with an empty name is a seriously
bad thing to allow, as it will mess up all the pattern matching
algorithms, etc. So, I added a statement to the add_extension2 code to return
a -1 if this is attempted.

git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@135265 65c4cc65-6c06-0410-ace0-fbb531ad65f3
main/features.c
main/pbx.c