fix one more warning missed because i did not have new enough libpri installed