Compatibility fix for glibc 2.4