Resolve a warning from gcc 4.4.1.