Compatibility fixes for loader changes