Include poll-compat.h