Compatibility issues on app_cut (bug #428)